Включение web интерфейса cisco

Содержание
  1. СОДЕРЖАНИЕ:
  2. Быстрый сброс Cisco 2960 на заводские настройки
  3. Сброс настроек (пароля) на Cisco 2960 с помощью командной строки
  4. Настройка коммутатора Cisco Catalyst 2960 с нуля
  5. Как прописать на различные порты Cisco определенные VLAN
  6. Создание и настройка VLAN в cisco packet tracer на коммутаторе Cisco Catalyst 2960
  7. Настройка ssh подключения к Cisco
  8. Как настроить ssh на Cisco Switch catalyst 2960 с помощью командной строки
  9. Настройка DHCP на роутере Cisco
  10. Настройка Cisco 2960 Netflow
  11. Конфигурирование Netflow на роутерах Cisco Router и Solar Winds netflow analyzer
  12. Настройка удаленного доступа на Cisco через Web интерфейс
  13. Включение https сервера на оборудование Cisco
  14. Настройка времени на Cisco 2960
  15. Настройка QoS очередей на платформах коммутаторов Cisco
  16. Настройка PoE на cisco 2960
  17. Подключаемся по HyperTerminal
  18. Порт LAN и WAN
  19. Несколько важных команд
  20. еnable
  21. conf t
  22. username имя privilege 15 secret пароль
  23. wr mem
  24. Настраиваем цыску через консоль
  25. Настройка DNS-серверов
  26. ip domain-lookup
  27. ip name-server X.X.X.X
  28. Настройка локальной сети
  29. interface Vlan1
  30. ip address 192.168.D.1
  31. ip virtual-reassembly
  32. ip dhcp excluded-address 192.168.D.1 192.168.D.99
  33. ip dhcp pool LAN
  34. network 192.168.D.0 255.255.255.0
  35. dns-server 192.168.D.1
  36. default-router 192.168.D.1
  37. Включаем графический интерфейс
  38. Установим графический web-интерфейс
  39. Настройка Интернет- подключения
  40. А если – PPPoE?
  41. В заключение – настройка Wi-Fi
  42. В графическом интерфейсе, настройки выполняют на вкладке «Configure»:
  43. Настройка удаленого доступа на Cisco через Web интерфейс
  44. Включение http сервера на оборудование Cisco.
  45. Включение https сервера на оборудование Cisco.

На это странице вы найдете большую подборку руководств по настройке коммутаторов Cisco Catalyst 2600.

СОДЕРЖАНИЕ:

  • Быстрый сброс Cisco 2960 на заводские настройки
  • Сброс настроек (пароля) на Cisco 2960 с помощью командной строки
  • Настройка коммутатора Cisco Catalyst 2960 с нуля
  • Как прописать на различные порты Cisco определенные VLAN
  • Создание и настройка VLAN в cisco packet tracer на коммутаторе Cisco Catalyst 2960
  • Настройка ssh подключения к Cisco
  • Как настроить ssh на Cisco Switch catalyst 2960 с помощью командной строки
  • Настройка DHCP на роутере Cisco
  • Настройка Cisco 2960 Netflow
  • Конфигурирование Netflow на роутерах Cisco Router и Solar Winds netflow analyzer
  • Настройка удаленного доступа на Cisco через Web интерфейс
  • Настройка времени на Cisco 2960
  • Настройка QoS очередей на платформах коммутаторов Cisco
  • Настройка PoE на cisco 2960

Быстрый сброс Cisco 2960 на заводские настройки

Сброс настроек (пароля) на Cisco 2960 с помощью командной строки

Подключите терминал или PC с программой эмуляции терминала к консольному порту маршрутизатора. Если пароль на консольный доступ не установлен, наберите show version и запишите значение конфигурационного регистра в самом конце вывода этой команды. Обычно это 0x2102 or 0x102.

Выключите и включите маршрутизатор. Пошлите сигнал Break в течение первых 30 с после включения. Вы должны увидеть приглашение rommon> в командной строке. Если этого не произошло, значит, Вы не послали маршрутизатору сигнал Break. Полезно, кстати, проверить настройки терминального доступа Вашей программы. Они должны быть такими — 9600, 8-«n»-1, no flow control. Наберите confreg. Ответьте ««y»» на вопрос «Do you wish to change configuration[y/n]?» Отвечайте «n» на все остальные вопросы, пока не увидите вопрос «ignore system config info[y/n]?». Ответьте «y». Отвечайте «n» на все оставшиеся вопросы до тех пор, пока не увидите вопрос «change boot characteristics[y/n]?». Ответьте «y». Ответьте «no» на вопрос «Do you wish to change configuration [y/n]?». Напечатайте reset. После перезапуска ответьте «no» на приглашение начать процедуру Setup.

Наберите enable в строке Router>. Вы должны увидеть Router#. Теперь можете посмотреть на конфигурационный файл (команда show startup-config). Если пароль в нем зашифрован, то наберите copy startup-config running-config. Затем наберите conf t и enable secret [новый пароль]. Нажмите sZ. Наберите copy running config startup-config. Наберите config t. Наберите config register 0x2102 (или то значение, которое вы записали). Нажмите sZ. Наберите reload. После перезагрузки должен начать действовать Ваш новый пароль.

Настройка коммутатора Cisco Catalyst 2960 с нуля

Как прописать на различные порты Cisco определенные VLAN

Создание и настройка VLAN в cisco packet tracer на коммутаторе Cisco Catalyst 2960

Настройка ssh подключения к Cisco

Несмотря на то, что устройства Cisco и имеют GUI интерфейс управления, его никто не использует, так как соединение ssh надежнее и подтверждает, что человек, который по нему подключился как минимум знает, что делает. Еще одним из преимуществ является, то что ssh соединение, это просто консольный ввод команд, а значит он кушает меньше трафика и требует меньшую сетевую пропускную способность, в отличии от графического GUI интерфейса, а это означает, что вы легко сможете управлять устройством из мест, где очень слабый интернет.

Как настроить ssh на Cisco Switch catalyst 2960 с помощью командной строки

Настройка DHCP на роутере Cisco

Настройка динамической раздачи IP адресов с помощью сервера DHCP. Суть настройки. Подробная инструкция конфигурирования маршрутизатора. Необходимые настройки для автоматической выдачи IP адресов.

Настройка Cisco 2960 Netflow

Это видео покажет, как сконфигурировать роутер Cisco для экспорта данных NetFlow используя NetFlow version 9 так же известный как Flexible NetFlow.

Конфигурирование Netflow на роутерах Cisco Router и Solar Winds netflow analyzer

Настройка удаленного доступа на Cisco через Web интерфейс

Включение http сервера на оборудование Cisco.

Заходим в привилегированный режим.

Входим в режим конфигурирования.

Router# configure terminal

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

Router(config)# access-list 1 permit 172.16.1.1

Заводим пользователея myuser с паролем UserPassWord.

Router(config)# username myuser privilege 15 secret UserPassWord

Включаем http сервер с локальной аутентификацией.

Router(config)# ip http server

Router(config)# ip http authentication local

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

Router(config)# ip http access-class 1

Включение https сервера на оборудование Cisco

Заходим в привилегированный режим.

Входим в режим конфигурирования.

Router# configure terminal

Задаем имя устройству mycisco

Router(config)# hostname Bullmastiff

Задаем доменное имя — mydomain.com

mycisco(config)# ip domain-name mydomain.com

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

mycisco(config)# access-list 1 permit 172.16.1.1

Заводим пользователея myuser с паролем UserPassWord.

mycisco(config)# username myuser privilege 15 secret UserPassWord

Выключаем http сервер и включаем https сервер с локальной аутентификацией.

mycisco(config)# no ip http server

mycisco(config)# ip http secure-server

mycisco(config)# ip http authentication local

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

mycisco(config)# ip http access-class 1

Вот и все, настройка доступа через веб интерфейс на оборудование cisco завершена.

Настройка времени на Cisco 2960

Установка времени на Cisco производится из привилегированного режима в который вы попадаете командой enable, далее пишем вот такую команду:

clock set 13:53:00 28 nov 2018 где идет время потом месяц и год.

Сразу же сохраним и в память оборудования эту дату командой clock update-calendar иначе после перезагрузки у вас она слетит на 1993 год, работает данная команда не везде, где ее нет нужно использовать NTP сервер.

Для того, чтобы теперь посмотреть время на Cisco вы можете воспользоваться командой: sh clock

Настройка QoS очередей на платформах коммутаторов Cisco

Настройка PoE на cisco 2960

Switch# configure terminal

Switch(config)# interface gigabitethernet2/0/1

Switch(config-if)# power inline port poe-ha

Включение / Выключение PoE на интерфейсе коммутатора:

Ввод auto (значение по умолчанию) настраивает интерфейс на автоматическое распознание требуемой мощности и предоставляет питание, если требуемая мощность доступна. Ввод never запрещает PoE на интерфейсе.

Цены на сайте указаны с НДС.

При безналичном расчете цена не меняется.

Доставка по России, в Казахстан, в Беларусь. По Москве БЕСПЛАТНО!

Оперативный подбор оборудования и аналогов.

Если у вас – новый роутер Cisco, даже самый «простой» (например, Cisco 851), настроить его «без консоли» изначально – нельзя. То есть, вам понадобится компьютер с СОМ-портом (либо, качественным переходником), который вы подключаете к роутеру терминальным кабелем. Любой Cisco роутер, позволяет «настройку» и по Telnet, и даже через графический интерфейс, но все это – затем, уже после того, как вы подключитесь к нему «терминалом».

Подключаемся по HyperTerminal

Терминальных программ (таких, как «HyperTerminal» в Windows) – существует большое количество. При создании подключения, нужно выбрать верный СОМ-порт:

И затем, параметры соединения: 9600, 8, «нет», 1, «нет». Это – обязательно:

Имя пользователя для входа на новый роутер: cisco (и пароль – тот же).

Про аппаратное подключение, необходимо заметить, что: терминальный кабель (разъем COM-порта – со стороны, подключаемой к компьютеру) – вы устанавливаете при выключенном питании роутера. На самом роутере, терминальный разъем – всегда один (с правой стороны):

Конечно, подключение кабеля должно быть выполнено до запуска терминальной программы.

Порт LAN и WAN

Роутер – должен «получать» Интернет с порта WAN, и раздавать его дальше (в локальную сеть). В рассматриваемых моделях, используется 5 интерфейсов Ethernet, из которых последний (Eth4) – является портом «WAN».

Все порты (от 0-го до 4-го), доступны по именам (например, «Eth0»). При этом, порты «Eth0»- «Eth3» соединены с еще одним «портом» vlan1 через виртуальный «свич» (коммутатор).

Несколько важных команд

Когда вы находитесь в консоли, включите роутер. На вопрос о запуске «мастера», ответьте «n» («Enter»). Если спросят пароль – это cisco. Наберите команду (нажмите «Enter»):

просмотр доступных команд

еnable

включение режима с «повышенным» доступом (после ее применения, значок «больше» – сменится на «решетку»);

conf t

режим изменения настроек, «конфигурирования» (любая команда – вносит изменения немедленно);

username имя privilege 15 secret пароль

вместо слов «имя» и «пароль», подставьте что-либо свое (то, что будет использоваться);

выход из «режима изменения настроек» (вместо этой команды, можно нажать клавишу «Контрол» и «Z»);

wr mem

сохранить сделанные изменения в постоянную флешь-память роутера

Еще, есть команда reload (перезагрузка). А также, erase (с атрибутом «startup-config», настройки – полностью сбросятся к «заводским»).

Выполните эти команды в указанном выше порядке. По умолчанию, telnet-выключен, как и сетевой интерфейс для графической оболочки (SDM). Рассмотрим, как настройка роутера cisco производится «в консоли».

Настраиваем цыску через консоль

Настройка DNS-серверов

Зайдите в режим с повышенным доступом (enable), затем – в режим «конфигурирования» (conf t) “как рассмотрено выше”.

ip domain-lookup

без нее, доступ по именам – не возможен.

Заметим, что DNS-сервер – может использоваться внутренний (встроенный в cisco)! По умолчанию – он включен. А выключить, можно так: «no ip dns server».

ip name-server X.X.X.X

вместо X, подставьте адрес DNS-сервера, предоставляемого провайдером.

На этом, настройка роутера cisco на DNS – полностью выполнена (что было не сложно, не так ли?). Можно сохранить изменения (командой «wr mem»).

Настройка локальной сети

Мы должны включить сервер DHCP, придумать локальный адрес IP для него, и установить диапазон адресов. Команды – необходимо набирать в режиме «конфигурирования»:

interface Vlan1

переход в режим настройки «порта» Vlan1;

ip address 192.168.D.1

присвоили «порту» IP – адрес, на этом же адресе – затем будет web-интерфейс (вместо D – любое число);

ip virtual-reassembly

включили сборку фрагментных пакетов;

Сервер DHCP – по умолчанию включен (выключают командой «no service dhcp»). Пишем:

ip dhcp excluded-address 192.168.D.1 192.168.D.99

пусть DHCP раздает адреса 100-255 (здесь D – заменим на то же число);

ip dhcp pool LAN

пул адресов под именем «LAN»;

network 192.168.D.0 255.255.255.0

указали параметры сети;

dns-server 192.168.D.1

в локальной сети, сервер DNS – именно с этим адресом;

default-router 192.168.D.1

похоже, так надо :).

Затем, выполняется «exit». В принципе, локальная сеть настроена.

Включаем графический интерфейс

Остался последний штрих – разрешить управление через графический интерфейс. Если это не нужно, данный блок – пропускаем. Команды – будут такие (в режиме «конфигурирования»):

  • ip http server
  • ip http secure-server
  • ip http authentication local ///без этой команды, в «web-интерфейс» – не попадем
  • line vty 0 4
  • privilege level 15
  • login local
  • exit

Теперь можно выполнить «wr mem» и «reload».

Установим графический web-интерфейс

Любой cisco роутер, может одновременно «понимать» команды с консоли, и из web-интерфейса.

Для этого, на компьютер устанавливается модуль Java («Jre», качать с java.com), и программа графического интерфейса (называется «SDM»). Обратите внимание: «SDM» можно установить на сам роутер (а не только в ПК), о чем – дополнительно «спросят» при установке.

Примечание: на браузере, должен быть снят запрет всплывающих окон. Если это IE – включите также и «запуск активного содержимого»:

Подсоедините патч-кордом сетевую карту ПК к роутеру (к любому порту от «3» до «0»). Сетевая карта компьютера – должна быть в режиме «автоматических» DNS и IP. Обесточьте роутер при подключении (соблюдайте требования электробезопасности)!

Рассмотрим, что получается, если запустить «SDM» на выполнение.

Вместо предустановленного (10.10..), нужен IP-адрес, придуманный ранее (присвоенный «порту» Vlan1). Галочку «HTTPS» – лучше снять.

Жмем «Launch», далее – соглашаемся с сертификацией. Видим окно:

Где – вводим логин и пароль (те, что придумали ранее, при выполнении «username»). Согласитесь еще раз с принятием сертификата:

Через пару секунд, появится «первая» вкладка – основное окно «SDM»:

Руководство по интерфейсу, находится здесь: www.cisco.com/en/US/docs/routers/access/cisco_router_and_security_device_manager/25/software/user/guide/SDM25UGD.html

Настройка Интернет- подключения

Под «протокол DHCP», настроить – проще всего:

  • Interface FastEthernet4 ///подайте эту команду в режиме «конфигурирования» (настраиваем 4-й порт)
  • ip address dhcp ///сказали, что порт 4, получает IP с внешнего DHCP;
  • ip virtual-reassembly ///включили сборку фрагментных пакетов;
  • duplex auto ///понятно;
  • speed auto ///тоже понятно;

И, все – будет работать. Не забывайте сохранять конфигурацию. Еще, можно добавить «ip cef» (для ускоренной коммутации).

Файервол, по умолчанию – не задействуется. Если вы его включите – трафик станет равным «0» (запрещено – все). Поэтому, нужно выполнить разрешающие команды для файервола, и только затем – его можно включить (здесь – не рассматриваем).

О настройках на VPN-протокол, можно прочитать здесь (http://www.xakep.ru/magazine/xa/125/134/1.asp). В обзоре, подробно рассматривают настройку «клиента PPTP» (в «официальной « документации – есть только «L2TP»).

А если – PPPoE?

Тогда команды – были бы следующими:

  • interface FastEthernet4 ///аналогично;
  • no ip address ///«динамический» адрес – назначается «DealerOne»-интерфейсу;
  • duplex auto ///понятно;
  • speed auto ///понятно;
  • pppoe enable group global
  • pppoe-client dial-pool-number 1 ///указали номер интерфейса (пула);
  • exit /// порт – настроен.
  • interface DialerOne
  • encapsulation ppp ///а что же еще?
  • dialer pool 1 ///связали «DialerOne» с порядковым номером пула;
  • dialer group 1
  • ppp authentication chap callin
  • ppp chap hostname имя ///заменить «имя» на нужное;
  • ppp chap password 7 пароль ///заменить (так же).

На этом – все выполнено (не забывайте «запоминать» все настройки). Дополнительно, в «DialerOne» – можно было добавить:

  • mtu 1492 ///впрочем, он – «не 0» и по умолчанию;
  • ip address negotiated ///для сброса и получения IP при «переподключении»;
  • fair-queue ///алгоритм какой-то (стохастический, вот!) – рекомендуют для ADSL.

Эти настройки – для случаев, если модем – включен в режиме «моста». Успешного роутинга!

В заключение – настройка Wi-Fi

Любой Cisco роутер wifi раздает не хуже других. Речь идет, в том числе, о модели «871W». Жаль только, что отсутствует «быстрый» 802.11 n. Но две антенны, работают, как и положено, в режиме «2х2» (то есть, пара каналов – одновременно).

Желающие разобраться с настройками в консоли – могут смотреть здесь (http://telecombook.ru/archive/network/cisco/wireless-network/79-cisco-871-wi-fi). Очень хорошее описание (как раз для этой модели), без каких-либо лишних «теорий».

Правда, в случае web-интерфейса, без консоли полностью – не обойтись.

В режиме «конфигурирования», нужно выполнить:

  • no service dhcp///выключаем;
  • interface Vlan1
  • ip address 10.77.244.197 255.255.255.224
  • interface fastEthernet 0
  • switchport trunk encapsulation dot1q
  • switchport trunk allowed vlan add vlan1
  • exit ///«порт» – был настроен.

Сохраните эти настройки (выполнив «wr mem»). После чего, можно зайти в графический web-интерфейс. Сетевую карту ПК, нужно настроить на IP: 10.77.244.1. Адрес web-интерфейса – теперь «10.77.244.197».

В графическом интерфейсе, настройки выполняют на вкладке «Configure»:

Сделайте выбор, как на рисунке («wireless»), нажмите «Launch Wireless App» (запустить «беспроводное» приложение). Откроется еще одно окно браузера, где (до запуска сети), можно настроить все свойства:

Как видим, сеть – выключена. Переходим, прежде всего, на последнюю вкладку («Сервисы»):

Здесь, нужно нажать ссылку «VLAN». И (в появившемся) – «Routing»:

Настраиваем, как на рис. ниже:

То есть, «сеть» будет: 10.1.1.1/16. Только, не пытайтесь задать SSID. Переходим к закладке «Security» -> «SSID Менеджер»:

Где – выполняют настройки сети (в том числе, имени). По завершении, нажмите «Apply». Беспроводная сеть – начнет функционировать. Но сейчас, Cisco роутер wifi-сеть – раздает «без защиты».

Можно включить шифрование (в закладке «Encryption Менеджер»):

Допускается также «фильтрация MAC» (не будем рассматривать). Главное, настроить DHCP (так, чтобы адреса сети WLAN и VLAN – не пересекались, и были «в одной» сети). На вкладке «Configure», вы выбираете (в левой колонке): «Additional Tasks».

Раскрыв список «DHCP», прежде всего, удалите уже существующие (кнопка «Delete»). Создайте новый сервер «DHCP» (кнопкой «Add»), и настройте, как на рисунке:

  • Сложно настраивать?
  • Не являются обязательными DNS внутри роутера и идеальная скорость работы?

Тогда возможно, роутер Cisco Linksys (что-либо из «верхних» моделей) – станет хорошей альтернативой.

Настройка удаленого доступа на Cisco через Web интерфейс

Поговорим о том как включить на оборудование Cisco внутренний http, https сервер для удаленого управления через Web интерфейс.

Включение http сервера на оборудование Cisco.

Заходим в привилегированный режим.

Входим в режим конфигурирования.

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

Заводим пользователея myuser с паролем UserPassWord.

Включаем http сервер с локальной аутентификацией.

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

Включение https сервера на оборудование Cisco.

Заходим в привилегированный режим.

Входим в режим конфигурирования.

Задаем имя устройству mycisco

Задаем доменное имя — mydomain.com

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

Заводим пользователея myuser с паролем UserPassWord.

Выключаем http сервер и включаем https сервер с локальной аутентификацией.

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

Вот и все, настройка доступа через веб интерфейс на оборудование cisco завершена.

Оцените статью
Добавить комментарий