No Image

Транковые порты и порты доступа

СОДЕРЖАНИЕ
1 просмотров
11 марта 2020

ОСНОВНОЕ отличие — именно в этом. Что trunk порт может гонять тегированный трафик нескольких вланов, а аксесс порт будет принимать/отправлять нетегированный трафик, принадлежащий только одному влану (трафик как принадлежащий влану будет маркироваться только внутри коммутатора).

Неосновное отличие — trunk-порты могут поддерживать протоколы автоматического согласования режимов/VLAN’ов. Это протоколы DTP или VTP.

Коммутаторы можно связывать акцесс-портами в том случае, если вы стыкуете две инфраструктуры с пересекающимися вланами. Такой кейс возникает у интернет-провайдеров, например. Когда нужно подключить коммутатор клиента, и у вас на этого клиента выделен влан, скажем, 666. Но у клиента этот влан уже используется. Вы не можете ломать свой VLAN план, и клиент не может. Тогда вы настраиваете порт в сторону коммутатора клиента на 666 влан акцессом, а клиент на своей стороне настраивает акцесом порт в том влане, который у него выделен как стыковочный. Ну, к примеру, 777. И получается мир-дружба-жвачка, и все работают согласно своим VLAN-планам без всяких проблем. Но технически получается, что два коммутатора подключены акцесс-портами.

by_EL, В принципе коммутататоры можно связать acess линками. Но такая структура будет крайне не гибкой. собственно через один линк можно будет пропустить один Vlan. Иногда используется если надо быстро расширить портовую емкость какой то подсети в одном месте, но решение так себе.

Основная разница trunk тегированный трафик, куча Vlan. Access нетегированый трафик один влан.

Что еще добавить из таких глобальных отличий, затрудняюсь ответить.

понедельник, октября 08, 2012

Виртуальная реальность или что такое VLAN

Организация двух VLAN на коммутаторе
Принцип работы портов доступа и транковых портов
На данном рисунке все порты являются портами доступа
Один единственный VLAN на коммутаторе

39 коммент.:

Наоборот, статья очень простая благодаря наглядным примерам.

Спасибо! Очень доступно и о только о главном.

Хоть что-то прояснилось! Спасибо большое!

Рад что Вам пригодилась данная статья.

добрый день!! а сколько vlan может поддерживать порт в транке? и что за порты в режиме гибрид?

Добрый день. Если не ошибаюсь, то максимальное число vlan зависит от модели коммутатора и типа его программного обеспечения. Посмотреть максимальное число поддерживаемых vlan на коммутаторах catalyst можно с помощью команды show vtp status.
Режим гебрид мне пока не знаком. Но вроде бы неплохое его описание можно найти тут http://otvety.google.ru/otvety/thread?t >

А если вообще не настраивать порт? он будет работать?

Хорошая статья, спасибо!

"А если вообще не настраивать порт? он будет работать?"
Да будет. По умолчанию, обычно, все порты в рабочем состоянии.

спасибо огромное, все предельно просто. здорово объяснили

Верните пожалуйста рисунки.

Рисунки на месте, возможно были какие то технические проблемы в работе.

Поскольку основным назначением виланов на практике есть изоляция на уровне передачи данных (уровень 2, уровень Ethernet-кадров) широковещательного (бродкастового и мультикастового) трафика с сетевого уровня, то полезным, на мой взгляд, было бы приводить для наглядности в таких статьях как пример скриншоты работы сетевого анализатора с параметром вывода разницы во времени между пакетами/кадрами. Например, tcpdump -ttt ether broadcast. Это очень хорошо показывает, что было в общем сегменте (или дефолтном вилане) и что получилось в отдельном вилане.

Читайте также:  Как вернуть файл из карантина mcafee

"воскресенье, ноября 02, 2014"
Отличное предложение, сам да такого в момент написания статьи не догадался.

Здравствуйте. Получается в одной VLAN всё оборудование имеет одинаковый IP адрес? Спасибо.

Добрый день. Нет. Разные устройства имеют разные адреса, но из одной подсети.

Добрый день! Ну наконец-то в голове как-то системно что-то начало укладываться.) А можно сделать так что б у нескольких VLAN для выхода в интернет был один общий ip адрес?

Добрый день. Попробуйте прочитать про NAT. В этом блоге, к сожалению, я эту тему еще не освещал.

"Разные устройства имеют разные адреса, но из одной подсети." – это с какого перепугу? Они могут быть в разных подсетях, но в одном VLAN’e

Согласен. На практике, несколько подсетей будут работать вместе в одном VLAN, но лучше так не делать и предерживаться правила: один vlan – одна подсеть. Не могу привести ни одного примера где бы могло пригодиться несколько подсетей в одном VLAN.

К примеру. Провайдер Интернет. У провайдера много разных диапазонов адресов. Для изоляции домов друг от друга применяется схема "один дом – один VLAN" или даже "один подъезд – один VLAN". У клиентов внутри VLAN’a могут быть адреса с разных диапазонов.

Ок) Клиенты чаще всего за NATом сидят) Железка провайдера может и не знать об этих подсетях)

добрый день! подскажите какое оборудование(концентраторы, комутаторы, маршрутизаторы) понадобиться для построение офисной сети стандарта Fast Ethernet примерно на 70 ПК. Спасибо)

нужен ли вообще концентратор для такой сети? Если использовать многопортовый коммутатор

Концентраторы не нужные – это прошлый век. Вам нужны несколько коммутаторов и маршрутизатор.

добрый день! пишу дипломную работу(( подскажите расчеты основных параметров для сети Fast Ethernet. или источник откуда это можно взять.
2 если есть, то информацию по настройке сети( коммутаторы, маршрутизаторы D-Link)
зарание Спасибо.

Добрый день.
Попробуйте поискать что либо полезное для расчетов вот тут:
1.Кучерявый А. Е., Гильченок Л. З., Иванов А. Ю. Пакетная сеть связи общего пользования.
2.Битнер В.И., Михайлова Ц.Ц. Сети нового поколения – NGN.
3.Конахович Г. Ф., Чуприн В. М. Сети передачи пакетных данных.
Читал давно, но вроде в них что то должно быть по вашей теме.

Насчет D-Link, попробуйте найти для себя что то полезное вот здесь:
http://learn.dlink.ru/login/index.php

Egor , your explanations are just too good to be true! Bravo!

Егор, добрый день. Во-первых спасибо большое за прекрасный доступный материал. ВО-вторых, ламерский вопрос 🙂 ВОт есть у нас сеть с коммутаторами, на которых настроены виланы. Все также как и у вас в схеме, на коммутаторах – порты доступа, между коммутаторами – транковые порты на оптике на SFP модулях. Все прекрасно, но мне как новому админу надо иметь доступ со своей рабочей машины ко всем виланам. Правильно ли я понимаю что мне для этого достаточно сделать один из портов доступа на коммутаторе ядра, возле которого я сижу, транковым и подключить свою машину к нему? Ну на своей машине соответственно прописать еще один IP для другого вилана. Или надо делать сложнее и вроде как правильней, а именно настраивать маршрутизацию между виланами?

Читайте также:  Samsung pay на серых телефонах

Оба варианта имеют право на жизнь. Первый вариант проще реализуется (даже на простых свичах L2), второй, как Вы правильно заметили, сложнее, и реализуется с помощью оборудования L3 или программным путем на сервере маршрутизации.

Андрей, спасибо. Коммутаторы у нас как раз L3, но в сети есть софтовый интернет шлюз. Соответственно на всех компьютерах в сети он прописан к качестве дефолтного.Получается маршрутизацию в коммутаторах сейчас не использовать.

И еще вопрос, если можно. Что из себя представляет интерфейс управления коммутатором? Тот самый IP через который мы подключаемся к его вебморде и т.д. Где и как он прописывается?

to Андрей Григорьев
что то первый вариант не такой уж и живучий, как выясняется )) мало того что для распознавания тегированных пакетов сетевая карта должна быть соответствующая, так еще будет несколько сетевых интерфейсов по кол-ву виланов

Добрый день. Лично мне больше нравиться вариант с маршрутизацией.

Прописать IP для менеджмента можно примерно вот так(номер vlan заменить на необходимый):
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown

Итак, разберемся немного с режимами портов управляемых коммутаторов.

Режимы портов

Access port (порт доступа) — порт, находящийся в определенном VLAN и передающий не тегированные кадры. Как правило, это порт, смотрящий на конечное устройство.

  • Trunk port (магистральный порт) — порт, передающий тегированный трафик. Как правило, этот порт поднимается между сетевыми устройствами.

Access порты

Об этом режиме основы уже описаны здесь

Trunk порты

Для того чтобы передать через порт трафик нескольких VLAN, порт переводится в режим trunk.

Режимы интерфейса (режим по умолчанию зависит от модели коммутатора):

  • auto — Порт находится в автоматическом режиме и будет переведён в состояние trunk, только если порт на другом конце находится в режиме on или desirable. Т.е. если порты на обоих концах находятся в режиме «auto», то trunk применяться не будет.
  • desirable — Порт находится в режиме «готов перейти в состояние trunk»; периодически передает DTP-кадры порту на другом конце, запрашивая удаленный порт перейти в состояние trunk (состояние trunk будет установлено, если порт на другом конце находится в режиме on, desirable, или auto).
  • trunk — Порт постоянно находится в состоянии trunk, даже если порт на другом конце не поддерживает этот режим.
  • nonegotiate — Порт готов перейти в режим trunk, но при этом не передает DTP-кадры порту на другом конце. Этот режим используется для предотвращения конфликтов с другим «не-cisco» оборудованием. В этом случае коммутатор на другом конце должен быть вручную настроен на использование trunk’а.

По умолчанию в транке разрешены все VLAN. Для того чтобы через соответствующий VLAN в транке передавались данные, как минимум, необходимо чтобы VLAN был активным. Активным VLAN становится тогда, когда он создан на коммутаторе и в нём есть хотя бы один порт в состоянии up/up.

Читайте также:  Закон о социальных сетях 2018

VLAN можно создать на коммутаторе с помощью команды vlan. Кроме того, VLAN автоматически создается на коммутаторе в момент добавления в него интерфейсов в режиме access.

Перейдем к демонстрационной схеме. Предположим, что вланы на всех коммутаторах уже созданы (можно использовать протокол VTP).

Настройка статического транка

Создание статического транка:

sw1(config)# interface fa0/22
sw1(config-if)# switchport mode trunk

На некоторых моделях коммутаторов (на которых поддерживается ISL) после попытки перевести интерфейс в режим статического транка, может появится такая ошибка:

sw1(config-if)# switchport mode trunk
Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode.

Это происходит из-за того, что динамическое определение инкапсуляции (ISL или 802.1Q) работает только с динамическими режимами транка. И для того, чтобы настроить статический транк, необходимо инкапсуляцию также настроить статически.

Для таких коммутаторов необходимо явно указать тип инкапсуляции для интерфейса:

sw1(config-if)# switchport trunk encapsulation dot1q

И после этого снова повторить команду настройки статического транка (switchport mode trunk).

Динамическое создание транков (DTP)

Dynamic Trunk Protocol (DTP) — проприетарный протокол Cisco, который позволяет коммутаторам динамически распознавать настроен ли соседний коммутатор для поднятия транка и какой протокол использовать (802.1Q или ISL). Включен по умолчанию.

Режимы DTP на интерфейсе:

auto — Порт находится в автоматическом режиме и будет переведён в состояние trunk, только если порт на другом конце находится в режиме on или desirable. Т.е. если порты на обоих концах находятся в режиме «auto», то trunk применяться не будет.
desirable — Порт находится в режиме «готов перейти в состояние trunk»; периодически передает DTP-кадры порту на другом конце, запрашивая удаленный порт перейти в состояние trunk (состояние trunk будет установлено, если порт на другом конце находится в режиме on, desirable, или auto).
nonegotiate — Порт готов перейти в режим trunk, но при этом не передает DTP-кадры порту на другом конце. Этот режим используется для предотвращения конфликтов с другим «не-cisco» оборудованием. В этом случае коммутатор на другом конце должен быть вручную настроен на использование trunk’а.

Перевести интерфейс в режим auto:

sw1(config-if)# switchport mode dynamic auto

Перевести интерфейс в режим desirable:

sw1(config-if)# switchport mode dynamic desirable

Перевести интерфейс в режим nonegotiate:

sw1(config-if)# switchport nonegotiate

Проверить текущий режим DTP:

sw# show dtp interface

Разрешённые VLAN’ы

По умолчанию в транке разрешены все VLAN. Можно ограничить перечень VLAN, которые могут передаваться через конкретный транк.

Указать перечень разрешенных VLAN для транкового порта fa0/22:

sw1(config)# interface fa0/22
sw1(config-if)# switchport trunk allowed vlan 1-2,10,15

Добавление ещё одного разрешенного VLAN:

sw1(config)# interface fa0/22
sw1(config-if)# switchport trunk allowed vlan add 160

Удаление VLAN из списка разрешенных:

sw1(config)# interface fa0/22
sw1(config-if)# switchport trunk allowed vlan remove 160

Просмотр информации

Просмотр информации о транке:

sw1# show interface fa0/22 trunk

Просмотр информации о настройках интерфейса (о транке):

sw1# show interface fa0/22 switchport

Просмотр информации о настройках интерфейса (об access-интерфейсе):

Комментировать
1 просмотров
Комментариев нет, будьте первым кто его оставит

Это интересно
Adblock detector